ar71xx: remove superfluous include of asm/mach-ath79/pci.h
[openwrt/svn-archive/archive.git] / target / linux / ps3 / Makefile
index 7412a3644fd0f2c1fe209687923c106ba93ebc98..01b298975e56313758024b6ca922ae1dc524e0e7 100644 (file)
@@ -9,25 +9,26 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
+MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 SUBTARGETS=petitboot
+FEATURES:=powerpc64 broken
 
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.30.10
 
 KERNEL_CC:=
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build bootloader images for the Sony PS3 Game Console
-endef
+       Build for the Sony PS3 Game Console
+
+       The OpenWRT build will create both a 1st stage PS3-Linux image
+       suitable for programming into the PS3 flash memory, and a 2nd
+       stage PS3-Linux image suitable for loading via bootloaders or
+       the kexec utility.
 
-ifeq ($(CONFIG_TARGET_ps3_petitboot),y)
-# no generic patches required
-define Kernel/Prepare
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       $(call PatchDir,$(PATCH_DIR),)
+       Enable the Petitboot package to build a PS3 bootloader.
 endef
-endif
 
 KERNELNAME:="zImage"