Amend patch handling in ps3
[openwrt/svn-archive/archive.git] / target / linux / ps3 / Makefile
index aacb116ae18f0321ac309edb5f024ebb4df0e31a..20eed76e424c78933a4fe4484cc652a150d7528d 100644 (file)
@@ -9,8 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
+SUBTARGETS=petitboot
 
-LINUX_VERSION:=2.6.25.4
+LINUX_VERSION:=2.6.27.8
 
 KERNEL_CC:=
 
@@ -20,11 +21,15 @@ define Target/Description
        Build bootloader images for the Sony PS3 Game Console
 endef
 
-# no generic patches required
+ifeq ($(CONFIG_TARGET_ps3_petitboot),y)
+# no patches required
+# provide facility for specific patches
+PATCH_DIR=patches-petitboot
 define Kernel/Prepare
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
        $(call PatchDir,$(PATCH_DIR),)
 endef
+endif
 
 KERNELNAME:="zImage"