upgrade to 2.6.25.9
[openwrt/svn-archive/archive.git] / target / linux / ps3 / Makefile
index 653ba80def5072d22080fe3a4a16148e063056f0..3874d249d18df5fe76a1f550a75c20aacfeeddc3 100644 (file)
@@ -8,27 +8,24 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ps3
-BOARDNAME:=Sony PlayStation 3
-LINUX_VERSION:=2.6.23.16
+BOARDNAME:=Sony PS3 Game Console
+
+LINUX_VERSION:=2.6.25.9
+
 KERNEL_CC:=
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build bootloader images for the Playstation 3
-endef
-
-# no patches required
-define Kernel/Prepare/ps3
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
+       Build bootloader images for the Sony PS3 Game Console
 endef
 
+# no generic patches required
 define Kernel/Prepare
-       $(call Kernel/Prepare/ps3)
+       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
+       $(call PatchDir,$(PATCH_DIR),)
 endef
 
-# include the profiles
-#-include profiles/*.mk
-
 KERNELNAME:="zImage"
+
 $(eval $(call BuildTarget))