Backport of ps3vram from 2.6.29
[openwrt/svn-archive/archive.git] / target / linux / ps3 / Makefile
index 14dbc9779680d4c739744cc59988c4fc56b63f53..4b2519befd6ca6ecf5bd72a2ec4540567cc50ce9 100644 (file)
@@ -9,25 +9,33 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
+MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+SUBTARGETS=petitboot
 
-LINUX_VERSION:=2.6.25.4
+DEVICE_TYPE=bootloader
+
+LINUX_VERSION:=2.6.28.8
 
 KERNEL_CC:=
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build bootloader images for the Sony PS3 Game Console
-endef
+       Build for the Sony PS3 Game Console
 
-# no patches required
-define Kernel/Prepare/ps3
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
+       The OpenWRT build will create both a 1st stage PS3-Linux image
+       suitable for programming into the PS3 flash memory, and a 2nd
+       stage PS3-Linux image suitable for loading via bootloaders or
+       the kexec utility.
+
+       Enable the Petitboot package to build a PS3 bootloader.
 endef
 
-define Kernel/Prepare
-       $(call Kernel/Prepare/ps3)
+ifeq ($(CONFIG_TARGET_ps3_petitboot),y)
+define Kernel/Patch
+# no patches required
 endef
+endif
 
 KERNELNAME:="zImage"