another round of kernel config cleanups
[openwrt/svn-archive/archive.git] / target / linux / ps3 / Makefile
index 1124ab6532de862dcd965e6225df89bbf3db2df9..79f17fb0c7c3251ec31a05bebe24d28d4a17079e 100644 (file)
@@ -9,21 +9,25 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
+MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+SUBTARGETS=petitboot
+FEATURES+=powerpc64
 
-LINUX_VERSION:=2.6.25.10
+LINUX_VERSION:=2.6.30.9
 
 KERNEL_CC:=
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build bootloader images for the Sony PS3 Game Console
-endef
+       Build for the Sony PS3 Game Console
+
+       The OpenWRT build will create both a 1st stage PS3-Linux image
+       suitable for programming into the PS3 flash memory, and a 2nd
+       stage PS3-Linux image suitable for loading via bootloaders or
+       the kexec utility.
 
-# no generic patches required
-define Kernel/Prepare
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-       $(call PatchDir,$(PATCH_DIR),)
+       Enable the Petitboot package to build a PS3 bootloader.
 endef
 
 KERNELNAME:="zImage"