kernel: update to kernel 2.6.32.9
[openwrt/svn-archive/archive.git] / target / linux / pxa / Makefile
index 3e0e6cd3b33d945db9c1b8cea3f7edd3e8741a07..d728e776c018580d8fefabd2c0a363ca9454525b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=pxa
-BOARDNAME:=PXA
-FEATURES:=jffs2 broken
+BOARDNAME:=Marvell/Intel PXA2xx
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.32.9
 
-LINUX_VERSION:=2.6.21.5
+include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Stub for boards based on intel PXA
+       Build images for PXA2xx systems, eg. Gumstix.
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
+KERNELNAME:="uImage"
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))