kernel: update to kernel 2.6.32.9
[openwrt/svn-archive/archive.git] / target / linux / pxa / Makefile
index d4d326f9a677a3bbd9d34cf2f956139d6bdfd4a6..d728e776c018580d8fefabd2c0a363ca9454525b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,20 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=pxa
 BOARDNAME:=Marvell/Intel PXA2xx
-FEATURES:=jffs2 broken
+FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.21.7
+LINUX_VERSION:=2.6.32.9
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build images for PAX2xx systems, eg. Gumstix.
+       Build images for PXA2xx systems, eg. Gumstix.
 endef
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
+KERNELNAME:="uImage"
 
 $(eval $(call BuildTarget))