kernel: update linux 3.3 to 3.3.5
[openwrt/svn-archive/archive.git] / target / linux / ramips / Makefile
index 85279d50d8cca1734a68aaca79f877fae49eb53c..6ac3901725170d2a4f8ec96c18062a8c94183162 100644 (file)
@@ -8,21 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.2.5
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
        kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini maccalc
+       kmod-rt2800-pci wpad-mini maccalc swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))