kernel: update 3.10 to 3.10.21
[openwrt/svn-archive/archive.git] / target / linux / ramips / Makefile
index 80719258b3ca25bf269937dabb0be5b64433db42..84ce8f0280e00d1dacc1eda6b583ab1f5d8531d1 100644 (file)
@@ -9,17 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
-FEATURES:=squashfs
+SUBTARGETS:=rt305x mt7620a mt7620n rt3883 rt288x
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.10.21
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini maccalc swconfig
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-rt2800-pci kmod-rt2800-soc wpad-mini swconfig
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.