kernel: update 3.10 to 3.10.32
[openwrt/svn-archive/archive.git] / target / linux / ramips / Makefile
index f4e20e6bdcee1be2e836cbb1b38210eff41d7364..a65646f779076955a9aa836f9fe64236d9fd5c3e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=2.6.37.4
+LINUX_VERSION:=3.10.32
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=kmod-leds-gpio wpad-mini
+DEFAULT_PACKAGES+=\
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-rt2800-pci kmod-rt2800-soc wpad-mini swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))