kernel: update 3.10 to 3.10.2
[openwrt/svn-archive/archive.git] / target / linux / ramips / Makefile
index 62262c656524acff78f421d2282bb2b2df57fe44..bb3f4f13929ac7752bec0a995fb4ea6f7886a0e2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt288x rt305x rt3883 mt7620a
+CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=2.6.30.6
+LINUX_VERSION:=3.10.2
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=\
+       kmod-leds-gpio kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-keys-polled kmod-button-hotplug \
+       kmod-rt2800-pci wpad-mini swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))