ramips: add kmod-usb-ohci to defaults packages in profile of ALL5002
[openwrt/svn-archive/archive.git] / target / linux / ramips / Makefile
index 0d82260acf3664f058261d1d0d98dde24d72b1cb..e49ff41a1283adc9431a9caed83a879196cd3ce5 100644 (file)
@@ -8,20 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.39.4
+LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev kmod-gpio-buttons \
-       kmod-button-hotplug kmod-rt2800-pci wpad-mini maccalc
+       kmod-leds-gpio kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-keys-polled kmod-button-hotplug \
+       kmod-rt2800-pci wpad-mini maccalc swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))