ramips: initial board support for Aztech HW550-3G
[openwrt/svn-archive/archive.git] / target / linux / ramips / image / Makefile
index 4cca2fcb34b69632704207f1c8b185d1c1c1326f..361588efcf68a7e30fc44e8fa9dc632a25be7453 100644 (file)
@@ -7,17 +7,15 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-IMGNAME:=$(BIN_DIR)/openwrt-$(BOARD)
-
 define imgname
-$(IMGNAME)-$(2)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
+$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)
 endef
 
-VMLINUX:=$(IMGNAME)-vmlinux
-UIMAGE:=$(IMGNAME)-uImage
+VMLINUX:=$(IMG_PREFIX)-vmlinux
+UIMAGE:=$(IMG_PREFIX)-uImage
 ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-       VMLINUX:=$(IMGNAME)-vmlinux-initramfs
-       UIMAGE:=$(IMGNAME)-uImage-initramfs
+       VMLINUX:=$(IMG_PREFIX)-vmlinux-initramfs
+       UIMAGE:=$(IMG_PREFIX)-uImage-initramfs
 endif
 
 ifeq ($(CONFIG_RALINK_RT305X),y)
@@ -47,11 +45,11 @@ define MkImage
 endef
 
 define Image/BuildKernel
-       cp $(KDIR)/vmlinux.elf $(VMLINUX).elf
-       cp $(KDIR)/vmlinux $(VMLINUX).bin
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(VMLINUX).elf
+       cp $(KDIR)/vmlinux $(BIN_DIR)/$(VMLINUX).bin
        $(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
        $(call MkImage,lzma,$(KDIR)/vmlinux.bin.lzma,$(KDIR)/uImage.lzma)
-       cp $(KDIR)/uImage.lzma $(UIMAGE).bin
+       cp $(KDIR)/uImage.lzma $(BIN_DIR)/$(UIMAGE).bin
 endef
 
 define BuildFirmware/Generic
@@ -90,6 +88,10 @@ define Image/Build/Profile/FONERA20N
        $(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
 endef
 
+define Image/Build/Template/PWH2004
+       $(call Image/Build/Template/GENERIC_8M,$(1),pwh2004,PWH2004)
+endef
+
 define Image/Build/Profile/V22RW2X2
        $(call Image/Build/Template/GENERIC_4M,$(1),v22rw-2x2,V22RW-2X2)
 endef
@@ -98,12 +100,45 @@ define Image/Build/Profile/WHRG300N
        $(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N)
 endef
 
+define Image/Build/Profile/HW5503G
+       $(call Image/Build/Template/GENERIC_8M,$(1),hw550-3g,HW550-3G)
+endef
+
+
+mtdlayout_wcr150gn=mtdparts=physmap-flash.0:192k(Bootloader)ro,64k(Config),64k(Factory),832k(Kernel),2944k(rootfs),3776k@0x50000(firmware)
+mtd_wcr150gn_kernel_part_size=851968
+mtd_wcr150gn_rootfs_part_size=3014656
+define Image/Build/Template/WCR150GN
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_wcr150gn,$(mtd_wcr150gn_kernel_part_size),$(mtd_wcr150gn_rootfs_part_size))
+endef
+
+define Image/Build/Profile/WCR150GN
+       $(call Image/Build/Template/WCR150GN,$(1),wcr150gn,WCR150GN)
+endef
+
+
+mtdlayout_f5d8235=mtdparts=physmap-flash.0:320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(factory),7744k@0x50000(firmware)
+mtd_f5d8235_kernel_part_size=1572864
+mtd_f5d8235_rootfs_part_size=6356992
+define Image/Build/Template/F5D8235V2
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_f5d8235,$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+endef
+
+define Image/Build/Profile/F5D8235V2
+       $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
+endef
+
+
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
+       $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
+       $(call Image/Build/Profile/WCR150GN,$(1))
+       $(call Image/Build/Profile/F5D8235V2,$(1))
+       $(call Image/Build/Profile/HW5503G,$(1))
 endef
 endif
 
@@ -113,7 +148,7 @@ endef
 
 define Image/Build
        $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(IMGNAME)-root.$(1) bs=128k conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
        $(call Image/Build/Profile/$(PROFILE),$(1))
 endef