ramips: add support for Omnima MiniEMBWiFi board
[openwrt/svn-archive/archive.git] / target / linux / ramips / image / Makefile
index 9136f3a5e263f3a3789c573dd82919c63e76c4cd..4f92d30ecd543000a2d675e73963eff623540327 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -107,6 +107,12 @@ define BuildFirmware/NW718
        fi; fi
 endef
 
+define BuildFirmware/Edimax
+       mkedimaximg -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+               -o $(call imgname,$(1),$(2))-factory.bin \
+               -s $(3) -m $(4) -f $(5) -S $(6)
+endef
+
 mtdlayout_4M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
 define Image/Build/Template/GENERIC_4M
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_4M,851968,3014656)
@@ -133,6 +139,12 @@ define Image/Build/Template/NW718
        $(call BuildFirmware/NW718,$(1),$(2),board=$(3),mtdlayout_nw718,851968,2949120)
 endef
 
+console_OMNIEMB=ttyS1,57600
+mtdlayout_ONMIEMB=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1024k(kernel),6848k(rootfs),7872k@0x50000(firmware)
+define Image/Build/Template/OMNIEMB
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) console=$(console_OMNIEMB),mtdlayout_OMNIEMB,1048576,7012352)
+endef
+
 define Image/Build/Profile/DIR300B1
        $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
        $(call Image/Build/Template/DIR300B1,$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
@@ -152,6 +164,11 @@ endef
 
 define Image/Build/Profile/FONERA20N
        $(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
+       $(call BuildFirmware/Edimax,$(1),fonera20n,RSDK,NL1T,0x50000,0xc0000)
+endef
+
+define Image/Build/Profile/BC2
+       $(call Image/Build/Template/GENERIC_8M,$(1),bc2,BC2)
 endef
 
 define Image/Build/Profile/NBG419N
@@ -162,6 +179,10 @@ define Image/Build/Profile/NW718
        $(call Image/Build/Template/NW718,$(1),nw718,NW718)
 endef
 
+define Image/Build/Profile/OMNIEMB
+       $(call Image/Build/Template/OMNIEMB,$(1),omni-emb,OMNI-EMB)
+endef
+
 define Image/Build/Profile/PWH2004
        $(call Image/Build/Template/GENERIC_8M,$(1),pwh2004,PWH2004)
 endef
@@ -191,15 +212,8 @@ define Image/Build/Profile/MOFI35003GN
        $(call Image/Build/Template/GENERIC_8M,$(1),mofi3500-3gn,MOFI3500-3GN)
 endef
 
-mtdlayout_wcr150gn=mtdparts=physmap-flash.0:192k(bootloader)ro,64k(config),64k(factory),832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
-mtd_wcr150gn_kernel_part_size=851968
-mtd_wcr150gn_rootfs_part_size=3014656
-define Image/Build/Template/WCR150GN
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_wcr150gn,$(mtd_wcr150gn_kernel_part_size),$(mtd_wcr150gn_rootfs_part_size))
-endef
-
 define Image/Build/Profile/WCR150GN
-       $(call Image/Build/Template/WCR150GN,$(1),wcr150gn,WCR150GN)
+       $(call Image/Build/Template/GENERIC_4M,$(1),wcr150gn,WCR150GN)
 endef
 
 
@@ -237,12 +251,14 @@ endef
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
+       $(call Image/Build/Profile/BC2,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
        $(call Image/Build/Profile/NBG419N,$(1))
        $(call Image/Build/Profile/NW718,$(1))
+       $(call Image/Build/Profile/OMNIEMB,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
@@ -253,6 +269,17 @@ define Image/Build/Profile/Default
 endef
 endif
 
+
+define Image/Build/Profile/RTN15
+       $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
+endef
+
+ifeq ($(CONFIG_RALINK_RT288X),y)
+define Image/Build/Profile/Default
+       $(call Image/Build/Profile/RTN15,$(1))
+endef
+endif
+
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef