ramips: mt7621: fix WF-2881 for ubi split
[openwrt/svn-archive/archive.git] / target / linux / ramips / image / Makefile
index eb50cddeaf75b772729f1e76ddc1e1001432766a..f5e8e58ef93afee7a8830750371e5e54af9f2113 100644 (file)
@@ -1115,9 +1115,10 @@ define Device/wf-2881
   DTS := WF-2881
   BLOCKSIZE := 128KiB
   PAGESIZE := 2048
-  KERNEL_SIZE := 2097152
   FILESYSTEMS := squashfs
-  IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+  IMAGE_SIZE := 132382720
+  KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+  IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Device/ubnt-erx