brcm63xx: update development kernel to linux 3.14
[openwrt/svn-archive/archive.git] / target / linux / ramips / modules.mk
index 179aba6a77e105f75cbba2872d99c648d22711a6..cff4d719a5745c7ddca6119eadc54b2ed739402d 100644 (file)
@@ -19,12 +19,26 @@ define KernelPackage/usb-rt305x-dwc_otg
 endef
 
 define KernelPackage/usb-rt305x-dwc_otg/description
 This driver provides USB Device Controller support for the
 Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
 endef
 
 $(eval $(call KernelPackage,usb-rt305x-dwc_otg))
 
+OTHER_MENU:=Other modules
+define KernelPackage/sdhci-mt7620
+  SUBMENU:=Other modules
+  TITLE:=MT7620 SDCI
+  DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+  KCONFIG:= \
+       CONFIG_MMC_SDHCI_MT7620
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
+  AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-mt7620))
+
 I2C_RALINK_MODULES:= \
   CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink
 
@@ -39,3 +53,23 @@ define KernelPackage/i2c-ralink/description
 endef
 
 $(eval $(call KernelPackage,i2c-ralink))
+
+define KernelPackage/sound-mt7620
+  TITLE:=MT7620 PCM/I2S Alsa Driver
+  DEPENDS:=@TARGET_ramips_mt7620a +kmod-sound-soc-core +kmod-regmap
+  KCONFIG:= \
+       CONFIG_SND_MT7620_SOC_I2S \
+       CONFIG_SND_MT7620_SOC_WM8960
+  FILES:= \
+       $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-i2s.ko \
+       $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-wm8960.ko \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
+  AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-mt7620-i2s snd-soc-mt7620-wm8960)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-mt7620/description
+ Alsa modules for ralink i2s controller.
+endef
+
+$(eval $(call KernelPackage,sound-mt7620))