ramips: enable second SPI for VoCore
[openwrt/svn-archive/archive.git] / target / linux / ramips / modules.mk
index 1c84598e4567aa71fa25ac8d8fd1d7f928aab50c..cff4d719a5745c7ddca6119eadc54b2ed739402d 100644 (file)
@@ -5,6 +5,40 @@
 # See /LICENSE for more information.
 #
 
+define KernelPackage/usb-rt305x-dwc_otg
+  TITLE:=RT305X USB controller driver
+  DEPENDS:=@TARGET_ramips_rt305x
+  KCONFIG:= \
+       CONFIG_DWC_OTG \
+       CONFIG_DWC_OTG_HOST_ONLY=y \
+       CONFIG_DWC_OTG_DEVICE_ONLY=n \
+       CONFIG_DWC_OTG_DEBUG=n
+  FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+  AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-rt305x-dwc_otg/description
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-rt305x-dwc_otg))
+
+OTHER_MENU:=Other modules
+define KernelPackage/sdhci-mt7620
+  SUBMENU:=Other modules
+  TITLE:=MT7620 SDCI
+  DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+  KCONFIG:= \
+       CONFIG_MMC_SDHCI_MT7620
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
+  AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-mt7620))
+
 I2C_RALINK_MODULES:= \
   CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink
 
@@ -19,3 +53,23 @@ define KernelPackage/i2c-ralink/description
 endef
 
 $(eval $(call KernelPackage,i2c-ralink))
+
+define KernelPackage/sound-mt7620
+  TITLE:=MT7620 PCM/I2S Alsa Driver
+  DEPENDS:=@TARGET_ramips_mt7620a +kmod-sound-soc-core +kmod-regmap
+  KCONFIG:= \
+       CONFIG_SND_MT7620_SOC_I2S \
+       CONFIG_SND_MT7620_SOC_WM8960
+  FILES:= \
+       $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-i2s.ko \
+       $(LINUX_DIR)/sound/soc/ralink/snd-soc-mt7620-wm8960.ko \
+       $(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
+  AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-mt7620-i2s snd-soc-mt7620-wm8960)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-mt7620/description
+ Alsa modules for ralink i2s controller.
+endef
+
+$(eval $(call KernelPackage,sound-mt7620))