kernel: upgrade to 2.6.30.8 and refresh patches
[openwrt/svn-archive/archive.git] / target / linux / ramips / patches-2.6.30 / 100-mips-ralink-core.patch
index 63bda672d2fb9f316240c6bbd0cf3b2d6936c518..d6635357bbdddf64afc1bb8921b029ad4b1206fc 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -603,6 +603,26 @@
- load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
+@@ -607,6 +607,26 @@ ifdef CONFIG_PHYSICAL_START
+ load-y                        = $(CONFIG_PHYSICAL_START)
  endif
  
 +#
@@ -14,7 +14,7 @@
 +# Ralink RT288x
 +#
 +core-$(CONFIG_RALINK_RT288X)  += arch/mips/ralink/rt288x/
-+cflags-$(CONFIG_RALINK_RT288X)        += -I$(srctree)//arch/mips/include/asm/mach-ralink/rt305x
++cflags-$(CONFIG_RALINK_RT288X)        += -I$(srctree)//arch/mips/include/asm/mach-ralink/rt288x
 +load-$(CONFIG_RALINK_RT288X)  += 0xffffffff88000000
 +
 +#
@@ -29,7 +29,7 @@
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -22,6 +22,9 @@
+@@ -22,6 +22,9 @@ choice
  config MACH_ALCHEMY
        bool "Alchemy processor based machines"
  
@@ -39,7 +39,7 @@
  config BASLER_EXCITE
        bool "Basler eXcite smart camera"
        select CEVT_R4K
-@@ -638,6 +641,7 @@
+@@ -638,6 +641,7 @@ source "arch/mips/basler/excite/Kconfig"
  source "arch/mips/jazz/Kconfig"
  source "arch/mips/lasat/Kconfig"
  source "arch/mips/pmc-sierra/Kconfig"
  source "arch/mips/sgi-ip27/Kconfig"
  source "arch/mips/sibyte/Kconfig"
  source "arch/mips/txx9/Kconfig"
+@@ -989,7 +993,7 @@ config BOOT_ELF32
+ config MIPS_L1_CACHE_SHIFT
+       int
+-      default "4" if MACH_DECSTATION || MIKROTIK_RB532
++      default "4" if MACH_DECSTATION || MIKROTIK_RB532 || RALINK_RT288X
+       default "7" if SGI_IP22 || SGI_IP27 || SGI_IP28 || SNI_RM || CPU_CAVIUM_OCTEON
+       default "4" if PMC_MSP4200_EVAL
+       default "5"