kernel: update 3.10 to 3.10.2
[openwrt/svn-archive/archive.git] / target / linux / ramips / patches-3.10 / 0011-PCI-MIPS-adds-rt2880-pci-support.patch
index 6641985fd284f471dbc4d9aee97dedd4723f0bf9..8db77a6ad601154bcd9401d31b13118bf961a746 100644 (file)
@@ -13,11 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  3 files changed, 283 insertions(+)
  create mode 100644 arch/mips/pci/pci-rt2880.c
 
-diff --git a/arch/mips/pci/Makefile b/arch/mips/pci/Makefile
-index 2cb1d31..77974ba 100644
 --- a/arch/mips/pci/Makefile
 +++ b/arch/mips/pci/Makefile
-@@ -41,6 +41,7 @@ obj-$(CONFIG_SIBYTE_BCM1x80) += pci-bcm1480.o pci-bcm1480ht.o
+@@ -41,6 +41,7 @@ obj-$(CONFIG_SIBYTE_BCM1x80) += pci-bcm1
  obj-$(CONFIG_SNI_RM)          += fixup-sni.o ops-sni.o
  obj-$(CONFIG_LANTIQ)          += fixup-lantiq.o
  obj-$(CONFIG_PCI_LANTIQ)      += pci-lantiq.o ops-lantiq.o
@@ -25,9 +23,6 @@ index 2cb1d31..77974ba 100644
  obj-$(CONFIG_TANBAC_TB0219)   += fixup-tb0219.o
  obj-$(CONFIG_TANBAC_TB0226)   += fixup-tb0226.o
  obj-$(CONFIG_TANBAC_TB0287)   += fixup-tb0287.o
-diff --git a/arch/mips/pci/pci-rt2880.c b/arch/mips/pci/pci-rt2880.c
-new file mode 100644
-index 0000000..e2c4730
 --- /dev/null
 +++ b/arch/mips/pci/pci-rt2880.c
 @@ -0,0 +1,281 @@
@@ -312,8 +307,6 @@ index 0000000..e2c4730
 +}
 +
 +arch_initcall(pcibios_init);
-diff --git a/arch/mips/ralink/Kconfig b/arch/mips/ralink/Kconfig
-index 026e823..cd13da8 100644
 --- a/arch/mips/ralink/Kconfig
 +++ b/arch/mips/ralink/Kconfig
 @@ -8,6 +8,7 @@ choice
@@ -324,6 +317,3 @@ index 026e823..cd13da8 100644
  
        config SOC_RT305X
                bool "RT305x"
--- 
-1.7.10.4
-