allow the user to change the rb532 rootfs size in menuconfig (fixes #1374)
[openwrt/svn-archive/archive.git] / target / linux / rb532-2.6 / image / Makefile
index 2ded1c078849af51ede68d476f0df23f5f1e2cbe..b35b0b1e7bb686278900de0f5239001fd03ee19d 100644 (file)
@@ -52,7 +52,7 @@ endef
 
 define Image/Build
        $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
-       ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf 16 $(KDIR)/root.$(1)
+       ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
 endef
 
 $(eval $(call BuildImage))