No longer mark rdc-2.6 as broken, squashfs is now working, thanks sn9
[openwrt/svn-archive/archive.git] / target / linux / rdc-2.6 / Makefile
index 323eb2c3f4103b8cfc2e6af7356d1db94a166084..df920ddeecf760af6eb7bcddc6f7625e2179c214 100644 (file)
@@ -6,9 +6,27 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH:=i386
+BOARD:=rdc
+BOARDNAME:=RDC x86
+FEATURES:=squashfs
+
+define Target/Description
+        Build firmware images for RDC3211 based routers
+        (e.g. Airlink101 AR525W, Linksys WRT54R)
+endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+    define Kernel/SetInitramfs
+       rm -f $(BUILD_DIR)/root/sbin/init
+       $(CP) $(GENERIC_PLATFORM_DIR)/files/init $(BUILD_DIR)/root/sbin/
+       $(CP) $(PLATFORM_DIR)/image/preinit.arch $(BUILD_DIR)/root/etc/
+    endef
+endif
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))