No longer mark rdc-2.6 as broken, squashfs is now working, thanks sn9
[openwrt/svn-archive/archive.git] / target / linux / rdc-2.6 / Makefile
index e38565931291292fbc14469d9a1216ce65830c68..df920ddeecf760af6eb7bcddc6f7625e2179c214 100644 (file)
@@ -9,23 +9,24 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC x86
-FEATURES:=broken jffs2
+FEATURES:=squashfs
 
 define Target/Description
         Build firmware images for RDC3211 based routers
-        (e.g. Airlink101 AR525W)
+        (e.g. Airlink101 AR525W, Linksys WRT54R)
 endef
 
-LINUX_VERSION:=2.6.19
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=443c265b57e87eadc0c677c3acc37e20
-
 include $(INCLUDE_DIR)/kernel-build.mk
 
-define Profile/Ralink
-  NAME:=Ralink WiFi (default)
-  PACKAGES:=kmod-rt61
-endef
-$(eval $(call Profile,Ralink))
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+    define Kernel/SetInitramfs
+       rm -f $(BUILD_DIR)/root/sbin/init
+       $(CP) $(GENERIC_PLATFORM_DIR)/files/init $(BUILD_DIR)/root/sbin/
+       $(CP) $(PLATFORM_DIR)/image/preinit.arch $(BUILD_DIR)/root/etc/
+    endef
+endif
+
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))