kernel: update linux 3.3 to 3.3.5
[openwrt/svn-archive/archive.git] / target / linux / rdc / Makefile
index 9936b687c5006f259ee9603f9a57a26ed159f180..5451971134dd849066248be93829a6e2f56feb7d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
+FEATURES:=squashfs jffs2 pci usb pcmcia broken
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=3.3.5
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-rdc321x-wdt
+DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \
+                   wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-rdc321x-wdt
 
 define Target/Description
         Build firmware images for RDC321x based routers