[x86:rdc]: x86 kernels target bzImage by default
[openwrt/svn-archive/archive.git] / target / linux / rdc / Makefile
index 98146dcc16687d967c557e6f11c9766c1b48978b..be5936cfcc6d79d54e9d07aa610c3054a13a0318 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,15 @@ ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci usb pcmcia
-CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
-SUBTARGETS:=amit ar525w r8610 dir-450 sitecom
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.10
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-rdc321x-wdt kmod-r6040
+DEFAULT_PACKAGES += wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-rdc321x-wdt
 
 define Target/Description
         Build firmware images for RDC321x based routers
@@ -25,7 +26,3 @@ define Target/Description
 endef
 
 $(eval $(call BuildTarget))
-
-$(eval $(call RequireCommand,lzma, \
-        Please install lzma-4.4x. \
-))