realview: drop 3.14 support
[openwrt/svn-archive/archive.git] / target / linux / realview / Makefile
index e565593571cd3913e47702ee86fcae42f2140c15..5b0a0408a257eda2754c783b0558905044814d3e 100644 (file)
@@ -10,10 +10,13 @@ ARCH:=arm
 BOARD:=realview
 BOARDNAME:=ARM Ltd. Realview board (qemu)
 FEATURES:=fpu ramdisk
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.7
+KERNEL_PATCHVER:=3.18
+
+DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -21,6 +24,6 @@ define Target/Description
        Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
-KERNELNAME:="zImage"
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))