kernel: update 3.10 to 3.10.32
[openwrt/svn-archive/archive.git] / target / linux / realview / Makefile
index 546fa9d347e2fd24a63fa21611688c5d503c4ab7..5fba2187f6a83a0b26ab31642534c4d80d76f92e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=realview
-BOARDNAME:=ARM Ltd Realview
-FEATURES:=squashfs jffs2 fpu
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
+BOARDNAME:=ARM Ltd. Realview board (qemu)
+FEATURES:=fpu ramdisk
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=3.10.32
+
+DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build images for ARM Ltd Realview boards to be run with qemu
+       Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
 KERNELNAME:="zImage"