[target s3c24xx] create subtarget "om gta02" in preparation for further s3c24xx-based...
[openwrt/svn-archive/archive.git] / target / linux / s3c24xx / Makefile
index 33c7a55480522a388378ccd3c0f6b70e9e19f5ea..0a051ff13738a7b103077e30dd3c50ff4cce647a 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,21 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=s3c24xx
-BOARDNAME:=s3c24xx
+BOARDNAME:=Samsung S3C24xx
 FEATURES:=jffs2
+CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
+SUBTARGETS:=openmoko-gta02
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.30.10
 
 DEVICE_TYPE=phone
 
 define Target/Description
-       OpenMoko gta02
-endef
-
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+       S3C24xx arm
 endef
 
 include $(INCLUDE_DIR)/target.mk