update to latest 2.6.27 and 2.6.30 kernels
[openwrt/svn-archive/archive.git] / target / linux / s3c24xx / Makefile
old mode 100755 (executable)
new mode 100644 (file)
index 66496fc..456fe64
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,10 +8,11 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=s3c24xx
-BOARDNAME:=s3c24xx
+BOARDNAME:=Samsung S3C24xx
 FEATURES:=jffs2
+CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.30.7
 
 DEVICE_TYPE=phone
 
@@ -20,6 +21,5 @@ define Target/Description
 endef
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += xglamo enlightenment
 
 $(eval $(call BuildTarget))