[xburst] jz4740 pm: Fix gpio suspend/resume. Turn pll off while in suspend and gate
[openwrt/svn-archive/archive.git] / target / linux / sibyte / Makefile
index aa8acea1ce470ef382929351bf73f90bd3b952de..7f7867bd48a18bb494d0bdbef6e3aee77741e456 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=sibyte
-BOARDNAME:=SiByte MIPS
-FEATURES:=broken
+BOARDNAME:=Broadcom/SiByte SB-1
+FEATURES:=fpu
+CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.32.9
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+define Target/Description
+       Build firmware images for Broadcom/SiByte SB-1 boards
+endef
 
 $(eval $(call BuildTarget))