[sibyte]: upgrade to 2.6.32.8
[openwrt/svn-archive/archive.git] / target / linux / sibyte / Makefile
index 74c15cb328e507de3c7ac097c0de2bb4052fed74..9146be55ec01dde83232ea4445cac74bc87fe2e7 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
-FEATURES:=broken
+FEATURES:=fpu
+CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.32.8
 
 include $(INCLUDE_DIR)/target.mk
 
+define Target/Description
+       Build firmware images for Broadcom/SiByte SB-1 boards
+endef
+
 $(eval $(call BuildTarget))