uml: fix the kernel config name override
[openwrt/svn-archive/archive.git] / target / linux / uml / Makefile
index 41d20ff9465151ae6077fac241533be887e4c4f0..9342b1fa90674bcfb9bb3bb2b0b19446ee61f93d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,14 +20,15 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext2
-LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
+FEATURES:=ext4 audio
 
-LINUX_VERSION:=2.6.28
+LINUX_VERSION:=2.6.37.6
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-mac80211-hwsim
+LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
+
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
 
 endif