define a shared IMG_PREFIX variable used as a basename for image files, it contains...
[openwrt/svn-archive/archive.git] / target / linux / uml / image / Makefile
index baf945f5073ab76a7f3c526e8cbc4b3df8361fc0..5e7247ecdd5976cb63adbc2ad6998c37e9da786d 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,8 +12,8 @@ define Image/Prepare
 endef
 
 define Image/Build
-       cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
-       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux
+       cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
 endef
 
 $(eval $(call BuildImage))