2.6.22 is released :)
[openwrt/svn-archive/archive.git] / target / linux / x86-2.6 / Makefile
index 59f02b33404279264126f534b6c85d937a91e012..ae0bd4d4c5bd7743bf6f6ca439faf1c64cace871 100644 (file)
@@ -6,16 +6,18 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+ARCH=i386
+BOARD:=x86
+BOARDNAME:=x86
+FEATURES:=squashfs jffs2 ext2
+
+LINUX_VERSION:=2.6.22
 
-include ./config
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@