x86: Update kernel for alix2 to 3.10.15
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index ae10d165adf5275fea22fb18e2e92c239a5fbd93..0d4fe4764f4e1c588c52052c99f88c6a832750b9 100644 (file)
@@ -1,21 +1,23 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
+          rdc
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=3.3.8
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))