x86: switch to 2.6.31
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index d1e459ce818df515a4f3108780493842d6a27933..197da8be210007160d3b6777a367829f0220c561 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
+SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.31
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))
 
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+       Please install mkisofs. \
+))