[x86:rdc]: x86 kernels target bzImage by default
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index 60f09a9d865c3376a3e1631d248f23506fad4eab..3cbed95426c0219d639f040185f8228d2b9a263a 100644 (file)
@@ -1,21 +1,20 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk
-SUBTARGETS=generic
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
-LINUX_VERSION:=2.6.25.19
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))