x86: update to linux 3.14
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index afff2c6a6af5a99fc8fe88e0790028d34d9c428a..52d9885e5c6e2bc0bec7e1eb49537292e8be5151 100644 (file)
@@ -1,21 +1,23 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic mediacenter
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
+          rdc
 
-LINUX_VERSION:=2.6.23.16
+KERNEL_PATCHVER:=3.14
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))