[x86] preinit: use grep -q where applicable
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index 30104153f55aa157f332a7c203642bbeea230ec8..7389530a76c4e8611c9b2d020a474d6ad1751008 100644 (file)
@@ -1,21 +1,20 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk
-SUBTARGETS=generic
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia tgz
+SUBTARGETS=generic olpc
 
-LINUX_VERSION:=2.6.27.8
+LINUX_VERSION:=2.6.31.12
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))