[kernel] update to 2.6.32.20
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index 771fd191f9b001457ec545bc4dabcf51cc60c89f..895bc5bbdbbb6f6c143fa44fc10d15e12e214416 100644 (file)
@@ -1,23 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.32.20
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
-
-# include the profiles
--include profiles/*.mk
 
 $(eval $(call BuildTarget))
 
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+       Please install mkisofs. \
+))