[kernel]: upgrade kernel versions to the latest stable ones
[openwrt/svn-archive/archive.git] / target / linux / x86 / Makefile
index 9943210312418fa2a55148493b464eb89f20b6d1..a1d7ec6255b7ad2965de469b5e3b55e322668150 100644 (file)
@@ -1,21 +1,20 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic
+FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))