[x86] Use wildcards to copy grub stage files, will cover both i386-pc and i386-openwr...
[openwrt/svn-archive/archive.git] / target / linux / x86 / image / Makefile
index 839646e547e96231916f754439cb631f0d5d7fa8..4d766399238170607e84dee4db7c9f3b759b827e 100644 (file)
@@ -49,9 +49,9 @@ ifneq ($(HOST_OS),Darwin)
   define Image/Prepare/grub
        # for the image builder
        $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage1 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage2 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/e2fs_stage1_5 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage1 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage2 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/e2fs_stage1_5 \
                $(KDIR)/
   endef
 else