[x86] image: use internal qemu-img for vmdk and vdi images
[openwrt/svn-archive/archive.git] / target / linux / x86 / image / Makefile
index 338c8e0a7492649e1c3e48ecc5f0f2cfe4f5be45..b5297bbff8b1a745d301d9b27959dc9380ce032a 100644 (file)
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_X86_VDI_IMAGES),)
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
-               VBoxManage convertfromraw -format VDI \
+               qemu-img convert -f raw -O vdi \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
                # XXX: VBoxManage insists on setting perms to 0600
@@ -191,15 +191,3 @@ define Image/Build
 endef
 
 $(eval $(call BuildImage))
-
-ifneq ($(CONFIG_X86_VDI_IMAGES),)
-  $(eval $(call RequireCommand,VBoxManage, \
-       You need VBoxManage to generate VirtualBox images. \
-  ))
-endif
-
-ifneq ($(CONFIG_X86_VMDK_IMAGES),)
-  $(eval $(call RequireCommand,qemu-img, \
-       You need qemu-img to generate VMware images. \
-  ))
-endif