fixed generation of iso images
[openwrt/svn-archive/archive.git] / target / linux / x86 / image / Makefile
index dd147b869a952ab678af81cc16a38b8e01f4d466..db83e324cc1ea9b0ddb795e8de43c91a5f5a4e9a 100644 (file)
@@ -85,8 +85,8 @@ define Image/BuildKernel
 endef
 
 define Image/Build
-       $(call Image/Build/$(1))
        $(call Image/Build/grub,$(1))
+       $(call Image/Build/$(1))
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
 endef