Fix building of iso filesystem
[openwrt/svn-archive/archive.git] / target / linux / x86 / image / Makefile
index 9bd2eada6b43fd0083832ae3512e7809f62104f3..e64fa19925614e6f791fca61453f698c7eb3ef13 100644 (file)
@@ -49,9 +49,9 @@ ifneq ($(HOST_OS),Darwin)
   define Image/Prepare/grub
        # for the image builder
        $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage1 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage2 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/e2fs_stage1_5 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage1 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage2 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/e2fs_stage1_5 \
                $(KDIR)/
   endef
 else
@@ -66,7 +66,7 @@ ifeq ($(CONFIG_X86_VDI_IMAGES),y)
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
                rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi || true
-               vditool DD $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi $(BIN_DIR)/openwrt-$(BOARD)-ext2.image
+               VBoxManage convertfromraw -format VDI $(BIN_DIR)/openwrt-$(BOARD)-ext2.image $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi
     endif
   endef
 endif
@@ -92,14 +92,15 @@ define Image/Build/squashfs
 endef
 
 define Image/Build/iso 
+       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
        $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-pc/stage2_eltorito \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage2_eltorito \
                $(KDIR)/root.grub/boot/grub/stage2_eltorito 
-       sed -i \
+       sed \
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
                -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
                -e 's#(hd0,0)#(cd)#g' \
-                $(KDIR)/root.grub/boot/grub/menu.lst 
+               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz 
        mkisofs -R -b boot/grub/stage2_eltorito -no-emul-boot -boot-load-size 4 -boot-info-table \
                -o $(KDIR)/root.iso $(KDIR)/root.grub 
@@ -111,9 +112,11 @@ endef
 
 define Image/Build
        $(call Image/Build/$(1))
+ifneq ($(1),iso)
        $(call Image/Build/grub,$(1))
        $(call Image/Build/vdi,$(1))
        $(call Image/Build/vmdk,$(1))
+endif
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
 endef
@@ -121,8 +124,8 @@ endef
 $(eval $(call BuildImage))
 
 ifeq ($(CONFIG_X86_VDI_IMAGES),y)
-  $(eval $(call RequireCommand,vditool, \
-       You need vditool to generate VirtualBox images. \
+  $(eval $(call RequireCommand,VBoxManage, \
+       You need VBoxManage to generate VirtualBox images. \
   ))
 endif