image: fix jffs2(_nand) image generation
[openwrt/svn-archive/archive.git] / target / linux / xburst / image / Makefile
index 49bb254164ced11d4e31476bec0023d3096984dd..08536075065a9210dde4479e3d62b925f587cab4 100644 (file)
@@ -4,11 +4,12 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE=256k 512k
 
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
 ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
 UBI_OPTS = -m 4096 -p 512KiB
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
@@ -25,14 +26,18 @@ endef
 
 
 define MkImageGzip
-       gzip -9 -c $(1) > $(1).gz
+       gzip -9n -c $(1) > $(1).gz
        mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
                -e $(call kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
                -d $(1).gz $(2)
 endef
 
+define Image/Prepare
+       $(call MkImageGzip,$(KDIR)/vmlinux,$(KDIR)/uimage)
+endef
+
 define Image/BuildKernel
-       $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
+       cp $(KDIR)/uimage $(UIMAGE)
 endef
 
 define Image/Build/squashfs