[xburst] Add subtarget for each device
[openwrt/svn-archive/archive.git] / target / linux / xburst / image / Makefile
index dcc97e7657d3f16237e015c8979d5d6182eddb58..0947db0549a7e5224a8b8455d556cd33a57af89f 100644 (file)
@@ -9,8 +9,23 @@ include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE=256k 512k
 
 
 JFFS2_BLOCKSIZE=256k 512k
 
+ifneq ($(CONFIG_TARGET_QI_LB60),)
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
 UBINIZE_OPTS = -m 4096 -p 512KiB
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
 UBINIZE_OPTS = -m 4096 -p 512KiB
+else
+UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
+UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
+endif
+
+ifneq ($(CONFIG_XBURST_UBOOT),)
+  define Build/Clean
+       $(MAKE) -C u-boot clean
+  endef
+
+  define Build/Compile
+       $(MAKE) -C u-boot compile
+  endef
+endif
 
 define Image/BuildKernel
        cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
 
 define Image/BuildKernel
        cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
@@ -21,8 +36,7 @@ define Image/Build/squashfs
 endef
 
 define Image/Build
 endef
 
 define Image/Build
-       $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(SUBTARGET)-root.$(1) bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))
 endef
 
 $(eval $(call BuildImage))