[lantiq]
[openwrt/svn-archive/archive.git] / target / sdk / files / Makefile
index ba488e380c9ebfbd1a0b9245af0a543b54e02799..f1e0eadbea86104e67d6c4b2af8e7c64006a59a0 100644 (file)
@@ -1,69 +1,54 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007 OpenWrt.org
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
 
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+SDK:=1
+export TOPDIR LC_ALL LANG SDK
+
+world:
+
+include $(TOPDIR)/include/host.mk
+
+ifneq ($(OPENWRT_BUILD),1)
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/depends.mk
+  include $(TOPDIR)/include/toplevel.mk
+else
+  include rules.mk
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include package/Makefile
+
+$(package/stamp-compile): $(BUILD_DIR)/.prepared
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @mkdir -p bin/packages
+       @touch $@
 
-DEVELOPER=1
-export DEVELOPER
-
-all: world
-
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
-endif
-
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+clean: FORCE
+       rm -rf $(BUILD_DIR) $(BIN_DIR)
 
-package/%: .pkginfo FORCE
-       $(MAKE) -C package $(patsubst package/%,%,$@) SDK=1
+dirclean: clean
+       rm -rf $(TMP_DIR)
 
-download: FORCE
-       $(MAKE) package/download
+# check prerequisites before starting to build
+prereq: $(package/stamp-prereq) ;
 
-world: FORCE
-       $(MAKE) package/compile
-       -( \
-               cd package; \
-               find . -maxdepth 2 -name Config.in | \
-                       sed -e 's,/Config.in,,g' | \
-                       xargs -r -n1 make compile -C; \
-       )
+world: prepare $(package/stamp-compile) FORCE
+       @for configfile in `find package -maxdepth 2 -name Config.in` ; do \
+               $(MAKE) compile -C `dirname $$configfile`; \
+       done
+       @$(MAKE) package/index
 
-clean: FORCE
-       rm -rf build_* bin
+.PHONY: clean dirclean prereq prepare world
 
-distclean: clean
-       rm -rf dl .pkg*
-
-.PHONY: FORCE
-FORCE:
+endif