[package/dropbear]: tune some more options by default to decrease size
[openwrt/svn-archive/archive.git] / toolchain / Makefile
index 2d8d88219da78ee764f8b76f9d30eee8eac4ef1e..141f478522e2aebd7f508d6dfb1fa3a91d205427 100644 (file)
@@ -1,72 +1,82 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Main makefile for the toolchain
 #
-include $(TOPDIR)/rules.mk
-
-TARGETS-y:=kernel-headers libnotimpl
-TARGETS-$(CONFIG_GDB) += gdb
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  TARGETS-y+=binutils gcc uClibc
-endif
+# Steps:
+# 1) toolchain/binutils/install
+#    build & install binutils
+# 2) toolchain/gcc/prepare
+#    build & install a minimal gcc, needed for steps 3 & 4
+# 3) toolchain/kernel-headers/install
+#    install kernel headers, needed for step 4
+# 4) toolchain/libc/prepare
+#    build & install libc headers & support files, needed for step 5
+# 5) toolchain/gcc/compile
+#    build & install an initial gcc, needed for step 6
+# 6) toolchain/libc/compile
+#    build & install the final libc
+# 7) toolchain/gcc/install
+#    build & install the final gcc
+# 8) toolchain/libc/install
+#    build & install libc utilities
+#
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
+curdir:=toolchain
 
-all: install
-download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
-clean: $(TARGETS_CLEAN)
-$(TARGETS_INSTALL): $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
+# subdirectories to descend into
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
+$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
+$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
 
-uClibc-prepare: kernel-headers-prepare
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  binutils-prepare: uClibc-prepare
-  gcc-prepare: binutils-install
-  uClibc-compile: gcc-compile
-  libnotimpl-compile: gcc-install
+# builddir dependencies
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  $(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
+  $(curdir)/gcc/minimal/compile:=$(curdir)/binutils/install
+  $(curdir)/kernel-headers/install:=$(curdir)/gcc/minimal/install
+  $(curdir)/gcc/initial/compile:=$(curdir)/$(LIBC)/prepare
+  $(curdir)/gcc/initial/prepare:=$(curdir)/gcc/minimal/prepare
+  $(curdir)/gcc/final/prepare:=$(curdir)/gcc/initial/prepare
+  $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/install
+  $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
+  $(curdir)/$(LIBC)/install:=$(curdir)/gcc/final/install
+  ifneq ($(CONFIG_GLIBC_PORTS),)
+    $(curdir)/glibc/prepare:=$(curdir)/glibc-ports/prepare
+  endif
 endif
-gcc-install: uClibc-install
-
-TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles
-
-$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME):
-       @mkdir -p $@
-       @ln -sf ../lib $@/lib
-
-$(TOOLCHAIN_STAMP_DIR):
-       mkdir -p $@
 
-$(TOOLCHAIN_BUILD_DIR):
-       @mkdir -p $@
-
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
+ifdef CONFIG_GCC_VERSION_LLVM
+  $(curdir)/builddirs += llvm
+  $(curdir)/gcc/minimal/compile += $(curdir)/llvm/install
+endif
 
-%-prepare: $(TOOLCHAIN_STAMP_DIR) $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) $(TOOLCHAIN_BUILD_DIR) FORCE
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+ifndef DUMP_TARGET_DB
+ifneq ($(ARCH),)
+  $(TOOLCHAIN_DIR)/info.mk: .config
+       @for dir in $(TOOLCHAIN_DIR); do ( \
+               set -x; \
+               mkdir -p "$$dir"; \
+               cd "$$dir"; \
+               mkdir -p stamp lib usr/include usr/lib ; \
+       ); done
+       @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
+       @touch $@
+endif
+endif
 
-%-compile: %-prepare 
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+# prerequisites for the individual targets
+$(curdir)/ := .config prereq
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
 
-%-install: %-compile
-       @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
-               $(MAKE) -C $(patsubst %-install,%,$@) install; \
-       }
-       @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
+ifndef DUMP_TARGET_DB
+$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+endif
 
-%-clean: FORCE
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$(patsubst %-clean,%,$@)-*
+$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
+$(eval $(call subdir,$(curdir)))