toolchain: make the default eglibc selection work even if TOOLCHAINOPTS is not enabled
[openwrt/svn-archive/archive.git] / toolchain / Makefile
index bdfb29ec1707ad54a0ddd820c7e64dff31c28981..36c6ed328a349a9848f8afc65f9294c34e3766f8 100644 (file)
@@ -9,19 +9,19 @@
 # Steps:
 # 1) toolchain/binutils/install
 #    build & install binutils
-# 2) toolchain/gcc/prepare
+# 2) toolchain/gcc/minimal/install
 #    build & install a minimal gcc, needed for steps 3 & 4
 # 3) toolchain/kernel-headers/install
 #    install kernel headers, needed for step 4
-# 4) toolchain/libc/prepare
+# 4) toolchain/libc/headers/install
 #    build & install libc headers & support files, needed for step 5
-# 5) toolchain/gcc/compile
+# 5) toolchain/gcc/initial/install
 #    build & install an initial gcc, needed for step 6
-# 6) toolchain/libc/compile
+# 6) toolchain/libc/install
 #    build & install the final libc
-# 7) toolchain/gcc/install
+# 7) toolchain/gcc/final/install
 #    build & install the final gcc
-# 8) toolchain/libc/install
+# 8) toolchain/libc/utils/install
 #    build & install libc utilities
 #
 
@@ -63,7 +63,8 @@ ifneq ($(ARCH),)
                $(if $(QUIET),,set -x;) \
                mkdir -p "$$dir"; \
                cd "$$dir"; \
-               ln -sf lib lib64; \
+               ln -nsf lib lib64; \
+               ln -nsf lib lib32; \
                mkdir -p stamp lib usr/include usr/lib ; \
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@