add a command for printing a cleaned up make target database - will be used to analyz...
[openwrt/svn-archive/archive.git] / toolchain / Makefile
index 3d8ba4c4ba462d03f703fa9a3139a05d1654f4c3..7c96c85e29bdcb3e19fb3abf0315f4686c12c1ca 100644 (file)
@@ -51,6 +51,7 @@ ifdef CONFIG_GCC_VERSION_LLVM
   $(curdir)/gcc/minimal/compile += $(curdir)/llvm/install
 endif
 
+ifndef DUMP_TARGET_DB
 ifneq ($(ARCH),)
   $(TOOLCHAIN_DIR)/info.mk: .config
        @for dir in $(TOOLCHAIN_DIR); do ( \
@@ -62,6 +63,7 @@ ifneq ($(ARCH),)
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
        @touch $@
 endif
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
@@ -69,7 +71,9 @@ $(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
 $(curdir)//compile = $(1)/prepare
 $(curdir)//install = $(1)/compile
 
+ifndef DUMP_TARGET_DB
 $(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+endif
 
 $(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
 $(eval $(call subdir,$(curdir)))